Electrical help please!

Discussion in 'Wiring' started by Willa, Sep 10, 2017.

  1. Willa

    Willa New Member

    2
    3
    Sep 10, 2017
    Hi! Im looking for some help if anyone has time. We have a 95 coleman popup. Everything worked fine last time we used it a couple months ago. Now getting it ready for the next trip, i can not get the overhead lights to work. All the outlets work though. And something that concerns me is the switch to conv, off, 12v does not work. As in, when i switch it to off, the outlets still work and i can still hear it running. It only has 2 circuits and it hums on circuit 1 and clicking it off and on didnt do anything but make it hum. Circuit 2 is the outlets and when i click it in and out, it works the plugs. #2 is not effected buy turning off #1
    Its not connected to any batteries at all. Just plugged into my house outlet. There is nothing else electric in it, just the inside lights and the outlets.
    I did check the connection at the top of the canopy post for the wires and all was good.
    Any ideas? Im worried the converter has gone bad or something. Its orginal to the camper. MagneTek series 6400A Model 6490.
    Also, there is a on/off switch right inside the door on the left hand side, that dosent do anything? What's it for?

    Thanks for your time and any suggestions!
     
  2. tombiasi

    tombiasi Well-Known Member

    4,282
    263
    Sep 1, 2012
    Northwestern New Jersey
    Did you check that the galley switch is fully depressed?
     
    Whiteycracker likes this.
  3. tombiasi

    tombiasi Well-Known Member

    4,282
    263
    Sep 1, 2012
    Northwestern New Jersey
    I forgot to say the outlets work from the plug in. Completely separate from the DC converter. The circuit breakers are housed in the same box but that's it.
     
  4. Willa

    Willa New Member

    2
    3
    Sep 10, 2017
    *sheepishly ducks head* Thank you! I didnt even realize there was a switch on the galley! I was like what switch? Theres nothing...wait...whats that?
    I had painted the cabinets and paint jamming it up. Cleaned that out and bam, lights again!
     
    Kampus, pasobuff and jmkay1 like this.
  5. jmkay1

    jmkay1 2004 Fleetwood/Coleman Utah

    2,807
    328
    Oct 10, 2013
    Northern Virginia
    Had a little scare myself This weekend for the same issue. My mom put the galley in place but,no lights. for 9 pm I was getting a bit worried, not something I wanted to solve that late at a campground. Turns out, A months ago I had a bit of a flood on my galley when I failed to take my cutting board sink cover off before turning on the water and thought I may have shorted my switch. Turned out in my mad dash to clean up my mess I had towel lint get into the switch which caused it to get stuck. So your not alone. [:I]
     
  6. Antipodes

    Antipodes Call me Paul

    774
    72
    Jan 28, 2015
    Christchurch, New Zealand
    Haha, no need to duck your head.
    I am sure we ALL have had those sorts of moments.
    Thanks for reporting back on it and nice to see you got it all going again.
     
    Lloyd B likes this.
  7. HotelRoyale

    HotelRoyale Member

    79
    29
    Sep 23, 2016
    The switch by the door should be for the courtesy light just above the stepper door ... at least that's the way it was on my old '92 Coleman Sequoia.
     
  8. Whiteycracker

    Whiteycracker Member

    58
    1
    May 22, 2016
    South Chicagoland
    I had the same thing happen. Got all set up and had issues...I was like #*&F(*F&G#*!!!!! And extremely tired from working midnights and wanted to sleep before the family came out. Low and behold something made me look under the sink for some reason....almost an hour or so later...lol. One of the wires came off the switch. Glad you resolved the issue!!
     

Share This Page