Site has been slow lately.

Discussion in 'Hey PUP Staff, Let me tell you what I think!' started by Sjm9911, May 11, 2019.

  1. David Blackwell

    David Blackwell Member

    Messages:
    51
    Likes Received:
    29
    Joined:
    May 10, 2017
    Location:
    San Diego, CA
    Steve - one more thing - a huge thank you for all of the work you obviously put in to maintain this website. I know I get a lot of this forum, and for that, I just wanted to say thank you very much.
     
    Sjm9911, neighbormike, Kampus and 7 others like this.
  2. Rik Peery

    Rik Peery Well-Known Member

    Messages:
    452
    Likes Received:
    312
    Joined:
    Jun 15, 2018
    Location:
    Virginia
    Just got on, too kalmost 2 minutes this time...
     
  3. durhamcamper

    durhamcamper Active Member

    Messages:
    687
    Likes Received:
    141
    Joined:
    Apr 21, 2010
    Location:
    Pickering, Ontario
    Windows 7 and Chrome. Worked flawlessly..........this time.
     
    Rik Peery likes this.
  4. MNTCamper

    MNTCamper Active Member

    Messages:
    748
    Likes Received:
    122
    Joined:
    Jun 14, 2014
    I'm on chrome and very slow to load initially and then for pages. This has been happening for me at least for the entire weekend, maybe a little bit earlier like on Friday - not sure.
     
    Rik Peery likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.