Thetford C-402C Fresh tank won't fill

Discussion in 'Port-A-Potties / Cassette Toilets / Bath Houses' started by Weekend Warrior, Feb 21, 2011.

  1. Weekend Warrior

    Weekend Warrior New Member

    27
    0
    Feb 12, 2011
    Hi Folks, I realize that there is another thread with the same issue but there wasn't a clear answer.

    I am having a problem filling the fresh water tank for toilet, I swing fill tube out and fill it with water but nothing happens. The water just sits in the tube and the level indicator does not change. I have filled the water to the point of almost reaching the top of the fill tube.

    Is the key to filling this tank to use the extention and fill it to the max position? Does this somehow allow water to enter the tank due to it's U shape.(read on another thread)

    I will try over filling later today but wondered if that little extention is more important than a simple funel and REQUIRED to fill you tank??

    Thanks for reading...
     
  2. Retired Alex

    Retired Alex New Member

    1,120
    3
    Oct 2, 2003
    Limoges, Ontario
    Do you have the manual for the toilet? If not go to Thetford's web site and get one. It describes how to fill and has pictures.
     
  3. armyguy

    armyguy US [USA]

    874
    0
    Dec 6, 2004
    Asheville NC
  4. arffch

    arffch Member

    324
    1
    May 25, 2009
    tulsa,ok.
    OK start simple, is the line to the level gauge plugged? Disconnect glass tube from rubber mount. pull tube down from rubber top and move to a horizontal position. does water flow from tube? this will locate where the "clog" is located.

    If water doesn't flow, blow into it like a straw and see if you can disloge the blockage.

    if water flows check the fill tube for clogs.

    good luck and let us know what you find!
     
  5. Weekend Warrior

    Weekend Warrior New Member

    27
    0
    Feb 12, 2011
    Okay found the problem. Thanks for all the help here folks, seems like I was on the right track after some earlier threads I'd found.

    Here's my explanation for those in the future who may need it...

    My problem was the fact that the water didn't go anywhere when I poured it in the fill spout. When I purchased the unit there was a little solution in the tank(probably for winterizing purposes) and it showed up in the indicating tube, I flushed the toilet a few times and sure enough the indicating tube went empty and so did the water in the tank.(no more solution when flushing). So, just fill up the tank with more water/solution right? That's where my problem was, I swung out the fill spout, put in the little funnel, poured in the water BUT, the water didn't go anywhere, it just filled up the fill spout!

    Here's fix....now keep in mind I put in enough water to almost get to the very top of the spout section and it didn't go anywhere. The fix is, just put a little more in! I read in another thread somewhere that because of the U shaped fill spout to tank you MUST fill the water to the rim. I literally added another cm to the water already in the spout and I'll be damned, it started filling the tank and showing up on the indicating tube as well.

    Go for it, keep pouring!!!
     
  6. 4mula1fan

    4mula1fan New Member

    168
    0
    Nov 1, 2008
    I put only clean water in the tank. Never any chemicals...
     
  7. Greg820

    Greg820 New Member

    40
    0
    Jul 13, 2014
    I realize this is a three-year-old topic, but we used our cassette toilet for the first time this weekend and I had the same problem. This thread saved my bacon when reading from the CG Friday night. Thanks! I'm starting to think that the RV world has secret standards to make sure all manuals are worthless.
     
  8. E3 Junkie

    E3 Junkie Greetings from Granada Hills, CA.

    314
    0
    Sep 22, 2012
  9. Revn

    Revn New Member

    16
    7
    May 2, 2018
    Peoria, AZ
    Phew thank goodness for this thread... got me past this issue and on to the next... why won’t it flush?? Lol see y’all in the next thread.
     
  10. Jason Barta

    Jason Barta New Member

    3
    0
    Jun 19, 2018
    Thank you! Saved me today with my family! Like you said just add slowly and it eventually starts to fill!!
     
  11. Tronicus

    Tronicus New Member

    4
    0
    Jun 3, 2018
    I am going to bump this, since it is one of the first seen things with a google search for this problem. I was cussin my RV salesman for 4 hours before I gave up and came in to read this solution. Mumbled to myself, went back outside, added about 4 oz's more water to the fill, and away it went, filling it up. THANKS!!
     
  12. Shayne Lovekin

    Shayne Lovekin New Member

    1
    0
    Aug 9, 2018
    Thanks Had the same prob and such an easy fix when you know [::)][::)] THANK YOU
     

Share This Page