tail lights not working

Just got my car all wired up to be able to tow the new camper. tested everything with a multimeter and circuit tester, all working properly.
When I got to the camper, I replaced the plug as it was corroded, removed about about an inch off the old wires to get nice clean connections.
how ever we get no power at all to any of the lights (blinker, brakes, etc). everything is wired correctly (triple checked).
The battery is dead, would that need to be replaced before the light would work?
I should mention that the inside camper lights and plugs and everything worked when plugged in to Shore Power.
 

SteveP

Super Active Member
Platinum Supporting Member
May 21, 2015
2,605
If you connected the wiring directly to your TV tail lights the lights may just be too faint to be visible due to the light weight wiring in your Captiva. You need a powered tail light converter to make them work properly.
 

Groomporter

Active Member
Jan 30, 2021
415
Minnesota
Thanks everyone, I did check for the fuse because I wasn't sure If i had one, and I did.

Turns out the power line from the battery to the converter came disconnected easy fix! Didn't see it originally because of the electrical tape. Put a new connection on there and ready to go!
Super. I had an issue fighting with the tail lights on mine too. After 30, or 40 minutes of switching wires back and forth on the new plug I finally checked the bulbs and realized when I was looking at them I put one of them in the wrong way around in the bayonet socket...
 

tfischer

A bad day camping beats a good day at the office
Glad you fixed it. I'm still somewhat confused though, because your towing lights and your interior convenience lights, converter, etc should be completely separate systems. You should be able to remove the battery completely and still tow.

I wonder if you have a ground issue, and things are somehow grounding through the converter?
 




Top